Description
A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).
One list of definitions is for “words” to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)
To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.
The definitions correspond to the rectangular grid by means of sequential integers on “eligible” white squares.White squares with black squares immediately to the left or above them are “eligible.” White squares with no squares either immediately to the left or above are also “eligible.” No other squares are numbered. All of the squares on the first row are numbered.
The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.
An “across” word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.
The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.
A “down” word for a definition is written on a sequence of white squares in a column starting on a
numbered square that does not follow another white square in the same column.
The sequence of white squares for that word goes down the column of the numbered square, ending
immediately before the next black square in the column or in the bottom square of the column.
Every white square in a correctly solved puzzle contains a letter.
You must write a program that takes several solved crossword puzzles as input and outputs the lists
of across and down words which constitute the solutions.
Input
Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and
Output
Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and thelist of across words followed by the list of down words.
Words in each list must be output one-per-linein increasing order of the number of their corresponding definitions.
The heading for the list of across words is ‘Across’.
The heading for the list of down words is ‘Down’.
In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’headings should still appear.
Separate output for successive input puzzles by a blank line.
Sample input
2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0
Sample output
puzzle #1:
Across
1.AT
3.O
Down
1.A
2.TO
puzzle #2:
Across
1.AIM
4.DEN
7.ME
8.ONE
9.UPON
11.TO
12.SO
13.ERIN
15.SA
17.OR
18.IES
19.DEA
Down
1.A
2.IMPOSE
3.MEO
4.DO
5.ENTIRE
6.NEON
9.US
10.NE
14.ROD
16.AS
18.I
20.A
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
char Puzzle[13][13];
int main(void)
{
int r, c;
int kase = 0;
//freopen("out.txt", "w", stdout);
while (scanf("%d", &r) && r)
{
scanf("%d", &c);
memset(Puzzle, 0, sizeof(Puzzle));
char ch;
while ((ch = getchar()) != '\n'&&ch != EOF);
for (int i = 1; i <= r; i++)
gets(Puzzle[i] + 1);
int identifer[13][13] = { 0 };
int number = 0;
for (int i = 1; i <= r; i++)
for (int j = 1; j <= c; j++)
if (Puzzle[i][j] != '*'&&(Puzzle[i - 1][j] == '*' || Puzzle[i][j - 1] == '*' || Puzzle[i - 1][j] == 0 || Puzzle[i][j - 1] == 0))
identifer[i][j] = ++number;
if (kase != 0)
printf("\n");
printf("puzzle #%d:\n", ++kase);
printf("Across\n");
for (int i = 1; i <= r; i++)
for (int j = 1; j <= c; j++)
if (identifer[i][j] != 0)
{
printf("%3d.", identifer[i][j]);
while (Puzzle[i][j] != '*'&&Puzzle[i][j] != 0)
{
printf("%c", Puzzle[i][j]);
j++;
}
printf("\n");
}
printf("Down\n");
for (int i = 1; i <= r; i++)
for (int j = 1; j <= c; j++)
if (identifer[i][j] != 0 && (Puzzle[i - 1][j] == '*' || Puzzle[i - 1][j] == 0))
{
int count = 0;
printf("%3d.", identifer[i][j]);
while (Puzzle[i][j] != '*'&&Puzzle[i][j] != 0)
{
printf("%c", Puzzle[i][j]);
i++;
count++;
}
i -= count;
printf("\n");
}
}
//system("pause");
return 0;
}
因篇幅问题不能全部显示,请点此查看更多更全内容